💻 개발/오늘의 삽질

[Android / Gradle] The current Gradle version is not compatible with the Kotlin Gradle plugin

고도고도 2022. 8. 9. 13:39

오늘 수도권에 비가 엄청 내려서 재택을 하게 됐다. 사내 깃과 연동이 되어 있지 않아서 프로젝트를 새로 생성해서 빌드를 하는데 아래와 같은 오류가 발생했다.

 

Gradle 버젼과 Kotlin Gradle Plugin 버젼이 맞지 않아 생기는 오류였다.

 

친절하게도 해결 방법을 알려준다.

 

android/gradle/wrapper/gradle-wrapper.properties를 수정하면 된다.

 

알려준 해결 방법대로 버젼을 6.7.0에서 6.7.1로 변경했는데 정상적으로 빌드가 됐다.

 

Gradle 버젼은 아래 링크에서 확인할 수 있다.

 

Gradle Distributions

 

services.gradle.org